You are not logged in.

XtC

Steuermann

  • "XtC" started this thread

Posts: 172

Date of registration: Jun 8th 2004

  • Send private message

1

Thursday, October 12th 2006, 6:45pm

[Tutorial] MP auch ohne Gamespy

Das ja einige von uns keine Lust auf Gamespy haben, haben wir nach einem Weg gesucht eine Multiplayerpartie auch ohne GS zu geniessen.

Folgendes Tool wird dafür benötigt: :hinweis: Hamachi (Link leider zerbröselt)
Dies wird dazu benötigt um einen VPN Tunnel zwischen den Rechnern aufzubauen damit das Spiel über den LAN Modus des Spiels abgewickelt werden kann.

[1]Wir installieren also Hamachi.
Wenn wir fertig sind kommt folgendes Bild:
*Bild leider weg*
Natürlich ohne den Netzwerknamen etc.

[2]Diesen müssen wir erst einrichten (nur einer der Spielteilnehmer muss das tun)
wir haben unseren Anno1701 Netzwerk genannt.
Ihr könnt ihn jedoch nennen wie ihr wollt.
Dazu klicken wir im Hamachi auf das kleine Symbol unten das aussieht wie ein Dreieck.
Dort wählen wir dann "Neues Netzwerk" aus und geben unserem Netz einen Namen.
Ihr könnt wenn ihr möchtet eurem Netzwerk auch ein Paawort geben das ist aber kein Muss.

[3] Daraufhin müsste sich Hamachi einwählen und oben im Programm sollte eure IP auftauchen.

[4]Nun könnt ihr den Namen eures Netzwerkes an eure Mitspieler weitergeben,
diese müssen im Himachifenster auch auf Dreieck unten klicken und dort auf "Netzwerk beitreten" klicken.
Dort müssen sie den Namen des Netzwerks eingebeben. Achtung: Bitte auf die genaue Schreibweise achten!!!

[5] Dann sollten alle Spieler im Hamachifenster auftauchen und jedem ist eine IP Adresse zugewiesen.

[6] Der Spieler der das Spiel hostet startet Anno1701 und geht dort unter Multiplayer auf "Lokales Netzwerk".

[7] Wenn er im Menü angekomme ist klickt er dort auf "Karte laden" und "Spielserver starten"

[8] Nun muss er noch Platz für die anderen Spieler schaffen indem er die Computergegner aus dem Spiel nimmt und den Platz auf "Offen" setzt.
Je nachdem wieviele Spieler teilnehmen wollen.

[9] Nun da wir Platz für die Spieler geschaffen haben gehen die anderen Spieler auch in das Menü "Multiplayer" und dort auf "Lokales Netzwerk".
Dort sollte nun in der "LAN Lobby" der Spieleserver auftauchen auf diesen wir nun connecten.

[10] Der Hoster muss so lange im Spieleservermenü warten bis alle Spieler eingetroffen sindm erst dann bitte auf "Mehrspieler Partei starten" klicken.

[11] Nun sollte das Game bei jedem Spieler anfangen zu laden.
Wenn dem so ist, viel Spaß beim zocken. :hey:

Nachtrag:
Ich habe noch weitere Netzwerke eingerichtet.

Anno1701 Netzwerk2
Anno1701 Netzwerk3
Anno1701 Netzwerk4

Wer Lust hat einen kleinen Netzwerkring aufzubauen der kann sich gerne bei mir melden.

MfG.: XtC


Wichtig: Wer trotz allem noch Verbindungsprobleme hat, sollte seine Hamachinetzwerkverbindung als erste deklarieren.

Hierzu geht ihr per rechtem Mausklick auf das Netzwerksymbol und ruft die Eigenschaften auf.
In der oberen Menueleiste dann auf Erweitert, und erweiterte Einstellungen.
Dort wird einem angezeigt welche Verbindungen bereits bestehen, die Hamachiverbindung kann dann einfach nach oben geschoben werden. ;)
  Kennt ihr schon Hein?
Ich will wissen wer Hein ist!

This post has been edited 1 times, last edit by "XtC" (Oct 14th 2006, 12:11pm)


nowrap

Is Seefest

Posts: 48

Date of registration: May 11th 2006

  • Send private message

2

Thursday, October 12th 2006, 7:00pm

danke für diese anleitung!
habe sie im offiziellen forum mal hierher verlinkt.

frage:
hast du eine lokale firewall verwendet und/oder die demo die windows firewall konfigurieren lassen?
 

XtC

Steuermann

  • "XtC" started this thread

Posts: 172

Date of registration: Jun 8th 2004

  • Send private message

3

Thursday, October 12th 2006, 7:01pm

Ich habe nutze zwar die NForce4 Firewall aber habe sie für die Versuche ausgeschaltet. Die Windows-Firewall ist bei mir generell aus.
  Kennt ihr schon Hein?
Ich will wissen wer Hein ist!

Schebberle

Leichtmatrose

Posts: 11

Date of registration: Oct 27th 2006

  • Send private message

4

Saturday, October 28th 2006, 10:13pm

ich weiß naich aber irgeniwe felht bei den servern das passwort
ich hab selber schon einige server gojoint wenn ich nur die namen eingebe kommt da auch , dass man n pw braucht könntest du das bitte noch posten????
  muss ich mir noch überlegen!!!!

annokrat

Schatzjäger

Posts: 4,774

Date of registration: Nov 15th 2003

  • Send private message

5

Saturday, October 28th 2006, 10:27pm

XtC,
benenne das programm bitte richtig. das ding nennt sich hamachi. (Edit by Admin: Die Schreibfehler wurden für unsere Suche korrigiert)
ausserdem finde ich zb hier eine version 1.0.0.62 beta:
http://hamachi.softonic.de/ie/38594

annokrat
  anno 1503, das beste anno aller zeiten.
anno 1701, das anno für ewige anfänger.

Deadviper

Frisch Angeheuert

Posts: 2

Date of registration: Jan 12th 2007

  • Send private message

6

Friday, January 12th 2007, 12:18am

Hallo

Habe ein Prob,will mit meinem Kumpel über Hamachi zocken das prob ist wir haben keinen Ping.Desweitern sind wir der Beschreibung genau gefolgt aber ohne Erfolg hat einer einen Tipp für uns wäre sehr verbunden.

mfg Dead

drahtwurm

Team AnnoZone

Posts: 514

Date of registration: Apr 10th 2005

  • Send private message

7

Friday, January 12th 2007, 12:38am

RE: Hallo

Hallo Deadviper,

erstmal willkommen hier on Bo(a)rd!

Der fehlende Ping ist ein Router- und Firewall - Problem, sollte aber bei Hamachi keine Rolle spielen.
Wie weit kommt Ihr?
Kommt ihr beide in ein gemeinsames Hamachi - Netzwerk?
Habt ihr die Hamachi IP des Servers eingegeben?
Habt ihr das Hamachi - Netzwerk an die Spitze der Lan - Verbindungen verschoben?
Könnt ihr euch in der 1701-Lobby sehen?
Habt ihr im Spiel einen Platz freigemacht?


Viel Spaß wünscht euch

Hans der Drahtwurm

Deadviper

Frisch Angeheuert

Posts: 2

Date of registration: Jan 12th 2007

  • Send private message

8

Friday, January 12th 2007, 5:09pm

Grüße nochmal,danke für die vielen Tipps haben es dann endlich hinbekommen nach vielen Stunden und brennenden Köpfen ;-)
Meine Firewall war schuld und jetzt geht es Super Freu

Danke nochmal und euch viel Spaß beim zocken

go-80

Landratte

Posts: 1

Date of registration: Jan 23rd 2007

  • Send private message

9

Wednesday, January 24th 2007, 12:04am

Hilfe

Hallo,
soweit haben wir die Anleitung befolgt, haben sogar bei Hamachi Ports definiert und diese im Router freigegeben, hatten zwischenzeitlich sämtliche Securitysoftware aus...aber leider leider finden wir uns in der Anno-Lobby nicht, woran könnte das liegen? Der Punkt mit den erweiterten Einstellungen ist uns nicht ganz klar, wir rechtsklicken auf das Hamchi Netzwerk Symbol, aber finden den Punkt einfach nicht. Oder könnte es an etwas anderem liegen? Probieren hier seit 2h alles mögliche und kommen nicht voran...
Vielen Dank für die Hilfe, MfG

This post has been edited 1 times, last edit by "go-80" (Jan 24th 2007, 12:05am)


eggi

Landratte

Posts: 1

Date of registration: Feb 25th 2007

  • Send private message

10

Sunday, February 25th 2007, 4:37pm

Geht nichts!

Hallo

Ich habe alles das probiert und gemacht mit meinem kumpel.... firewall ausgeschaltet, karte laden gemacht jedoch finden wir uns einfach nicht wenn wir aktualisieren klicken.... die einzige möglichkeit besteht mit der direktverbindung allerdings steht dort nach 5 sek. verbindungsaufbau (steige ins spiel ein), kein platz für weitere spieler...... obwohl alle pätze offen sind.... kann mit jemand weiterhelfen......

Kiffex

Landratte

Posts: 1

Date of registration: Jul 24th 2007

  • Send private message

11

Wednesday, July 25th 2007, 11:15am

wie kann ich das hamachi netzwerk den an die erste stelle setzten?
hab im LAN Modus von anno immer nur meine normal ip angezeigt obwohl Hamachi läuft.

Was muss ich machen???

W-O-D

Team AnnoZone

Posts: 6,854

Date of registration: Feb 3rd 2003

  • Send private message

12

Wednesday, July 25th 2007, 5:29pm

Geh mal auf die Netzwerkverbindung, und dann auf eigenschaften, da kannste dann festlegen welche Verbingung als erstes bedient wird. ;)
  Ich will meinen Scout zurück :keule:

Paul279

Leichtmatrose

Posts: 11

Date of registration: Dec 22nd 2006

  • Send private message

13

Monday, September 17th 2007, 8:31pm

Also mein Freund und ich haben auch irgendwie die Lobby zu finden!

also gleich im Vorraus:
meine Interne IP: 192.168.0.100
hamachi: 5.94.152...
und meine "Sehbare" IP im Netz ist immer verschieden!

Ich habe eine Portweiterleitung von meinem Router auf meine Interne IP gemacht(192.168....)

Wenn ich nun ein Spiel starte bei Anno und alles fertig eingestellt habe steht doch zum Schluss im Warteraum immer links unten meine Ip.
Dort steht meine Interne ip + 21701

Nun gebe ich meinem Kumpel meine Öffentliche die im Internet steht.

Die gibt er unter Direktverbindung ein irgendwas:21701 und passwort doch nichts!!!

Und unter Lobby ist auch nichts drinnen!


und wenn ichs über hamachi probiere! ich stelle sie an erster Stelle soll mein Mitspieler seine Lan auch auf die erste stelle schieben oder braucht er das nicht???

Aber wenn meine Hamachi an erster Stelle ist, habe ich doch die Portweiterleitung nicht auf hamachi gemacht sondern auf meine Interne IP 192.168.0.100
ist das in Ordnung?


Danke schon mal
lg Pauli

This post has been edited 2 times, last edit by "Paul279" (Sep 17th 2007, 8:48pm)


H.Seryoga

Frisch Angeheuert

Posts: 2

Date of registration: Oct 31st 2007

  • Send private message

14

Wednesday, October 31st 2007, 12:39pm

Quoted

Original von Paul279
Also mein Freund und ich haben auch irgendwie die Lobby zu finden!

also gleich im Vorraus:
meine Interne IP: 192.168.0.100
hamachi: 5.94.152...
und meine "Sehbare" IP im Netz ist immer verschieden!

Ich habe eine Portweiterleitung von meinem Router auf meine Interne IP gemacht(192.168....)

Wenn ich nun ein Spiel starte bei Anno und alles fertig eingestellt habe steht doch zum Schluss im Warteraum immer links unten meine Ip.
Dort steht meine Interne ip + 21701

Nun gebe ich meinem Kumpel meine Öffentliche die im Internet steht.

Die gibt er unter Direktverbindung ein irgendwas:21701 und passwort doch nichts!!!

Und unter Lobby ist auch nichts drinnen!


und wenn ichs über hamachi probiere! ich stelle sie an erster Stelle soll mein Mitspieler seine Lan auch auf die erste stelle schieben oder braucht er das nicht???

Aber wenn meine Hamachi an erster Stelle ist, habe ich doch die Portweiterleitung nicht auf hamachi gemacht sondern auf meine Interne IP 192.168.0.100
ist das in Ordnung?


Danke schon mal
lg Pauli


Habe hier vorhin ein Tutorial in nem anderem Forum zu Hamachi geschrieben, dass dein Porblem lösen kann, da es auf genau diesem Problem aufgebaut ist^^

http://www.hamachi-board.de/hamachi/tuto…machi/#post3432

This post has been edited 3 times, last edit by "H.Seryoga" (Oct 31st 2007, 12:42pm)


Goedecke

Frisch Angeheuert

Posts: 8

Date of registration: Dec 12th 2007

  • Send private message

15

Wednesday, December 12th 2007, 2:22pm

Multiplayer

moin moin

anno ist ein sehr gutes spiel...aber nur wenn man es alleine spielt :rofl:wir versuchen es seit drei wochen über game-spy zu spielen also über server :maeh:
es geht einfach nicht...und das problem haben viele leute :Dmeine meinung ist ganz einfach....es wird nie funktionieren :chrr:auch nicht mit hamachi...also lasst euch nichts erzählen.....

Excalibur3

R.I.P treuer Freund

Posts: 2,722

Date of registration: Mar 29th 2004

  • Send private message

16

Wednesday, December 12th 2007, 2:27pm

. . . hmm,

bezweifle nicht, das die MP-Spielerei optimal ist. Aber frage dich doch mal, warum es bei Anderen geht und das ist Fakt - sind die in ne Sonderauslosung gekommen :scratch: . . .

Goedecke

Frisch Angeheuert

Posts: 8

Date of registration: Dec 12th 2007

  • Send private message

17

Wednesday, December 12th 2007, 3:37pm

keine ahnung warum es bei anderen funzt :aua:wir sind sechs leute und es geht nicht...bei den meisten geht es nicht :ohoh:versuche haben wir genug gemacht...wahrscheinlich brauchen wir auch ein los der glücksspirale :scratch:an unseren pc´s liegt es nicht die sind alle ok :worry:die verbindungen der einzelen sind auch ok.....werd mir wohl ein anderes game holen :hey:

Posts: 313

Date of registration: Nov 2nd 2007

  • Send private message

18

Wednesday, December 12th 2007, 3:48pm

vieleicht hilft das hier euch weiter:
http://anno1701.die-offenbacher.de/

Bei mir hats so gefunct vieleicht auch bei euch :D

This post has been edited 1 times, last edit by "thomas der haundle" (Dec 12th 2007, 3:59pm)


Goedecke

Frisch Angeheuert

Posts: 8

Date of registration: Dec 12th 2007

  • Send private message

19

Wednesday, December 12th 2007, 3:55pm

ich werde es mal versuchen :rofl:danke für deine info :Ddenn es macht echt kein spass mehr wenn es nicht funzt :heul:

Daniel d'Artois

Insel-Eroberer

Posts: 419

Date of registration: Sep 12th 2006

  • Send private message

20

Wednesday, December 12th 2007, 4:08pm

Also wenn du diesem Tut folgst, kannst du dannach 100%ig im Mp spielen.

Deaktivier eben die Firewall, bevor du spielst.

(P.S.: Das musst du immer selber einstellen, wenn der pc ausgeschlatet wurde)

Über Gamespy gibt´s dann keine probleme.
  Mit freundlichen Grüßen, Daniel d'Artois,
bekannt wie die tratschende Heiligen-Tante aus Anno 1404!

* http://www.youtube.com/user/dangerniel01?feature=mhee *

This post has been edited 1 times, last edit by "Daniel d'Artois" (Dec 12th 2007, 4:18pm)